相信很多用wordpress的朋友最近想换到Openlitespeed (OLS),鉴于宝塔官方还没有让面板完能美兼容支持OLS,现在就一些常见问题我做一个汇总。https://cdn.31du.cn/images/2022/08/27/Q0xG.jpg

1. 换到Openlitespeed以后网站403错误?
这是关于permission方面问题,反正很难一步解决。建议备份好网站数据后,删除网站(保留数据),对面板的php和OLS也进行重装,最后再创建站点。如果是打算重新建立面板环境,请先装MYSQL+PHPMYADMIN,然后装Openlitespeed,最后装PHP8。亲测有效,宝塔面板会识别你装了OLS,然后智能安装php在OLS的文件夹里面。我也不知道为什么OLS要有自己的php而不像NGINX一样分开。总之,切换到OLS后,网站打不开了等等,宗旨就是删网站,重装php,重装OLS。实在不行,把VPS也重装了,从头来一遍,一定要备份好网站。

2.解决PHP8的一些拓展安装不了(Imagick拓展等等)?
我不知道是不是又是OLS不兼容的问题,但无妨,手动安装即可。教程请参考https://www.bt.cn/bbs/thread-77220-1-1.html。
重点说明,因为使用的是OLS,所以php的路径是不一样的。正确路径(拿php8版本举例),

cd imagick-3.5.1
/usr/local/lsws/lsphp80/bin/phpize
./configure –with-modules –with-webp –with-php-config=/usr/local/lsws/lsphp80/bin/php-config
复制代码
make && make install
复制代码
因为使用的OLS所以php.ini的路径也改了,
[imagick]
extension = /usr/local/lsws/lsphp80/lib64/php/modules/imagick.so
复制代码

3.怎么登录Openlitespeed的控制面板,登录信息哪里查看,OLS面板提示有新版本怎么升级?

重置OLS面板账号密码,
/usr/local/lsws/admin/misc/admpass.sh
复制代码
升级面板,现在最新版本为1.7.14,查看最新版本,
cat /usr/local/lsws/autoupdate/release
复制代码
然后执行OLS面板更新,
sudo /usr/local/lsws/admin/misc/lsup.sh -v 1.7.14
复制代码
以后版本就把版本号改了就行。

4.为什么我的Openlitespeed面板,提示Include file detected in configuration file. Entering Read-only mode.在配置文件中检测到包含文件,进入只读模式?
在宝塔面板上打开OLS的配置设计,把最后两行include注释#,之后就能在OLS面板上修改配置了(不建议自己瞎改)。注释掉以后网站,网页可能会出现打不开,只要取消注释就行了。

以后会接着补充内容。

发表回复

后才能评论