重要说明:

DiscuzX3.5目前还处于开发过程中,可能存在一些未知的风险和BUG,因此请大家暂时不要对生产环境进行升级。

升级心得:

众所周知,新版的DiscuzX3.5版本使用了全新的数据库编码utf8mb4环境。因此升级过程中,会对整个数据库的表和结构进行转码操作。这也就意味着,您不需要对老版本论坛进行转码了。不管你是GBK,还是UTF8,都可以通过升级文件直接升级。不过,需要注意的是,升级后,都变为UTF8版本。升级需要覆盖的论坛程序,请直接下载UTF8版本的程序。

升级方法:

从Discuz!X3.2-X3.4或其他基于此版本开发的未进行数据库结构变更的修改版本进行升级的升级流程

升级下载地址:https://gitee.com/oldhuhu/DiscuzX34235/tree/dev/

 

暂时不建议普通用户下载本分支代码,暂时不建议任何对生产站点的升级尝试,对生产站点升级前请假设在任何时间节点(含升级完成后)遇到的任何问题的解决方案均为恢复升级前的数据库备份并回退老版本!

简介

Discuz! X3.4 升级到 Discuz! X3.5 的升级程序及其他相关资源项目 Dev分支

声明

您可以 Fork 本站代码,但未经许可 禁止 在本产品的整体或任何部分基础上以发展任何派生版本、修改版本或第三方版本用于 重新分发

本软件及所附带的文件是作为 不提供任何明确的或隐含的赔偿或担保的形式 提供的。用户出于 自愿 而使用本软件,您必须了解 使用本软件的风险 ,在尚未购买产品技术服务之前,我们 不承诺提供任何形式的技术支持、使用担保 ,也 不承担任何因使用本软件而产生问题的相关责任

一旦您开始安装本产品( 此处以及本协议内的安装,应被解释为通过任何方式(包括但不限于下载、执行、使用、阅读或更改源代码等)对本软件的任何组成部分进行的任何行为 ),即被视为 完全理解并接受 授权协议所包含的各项条款

相关网站

Discuz! 官方站

感谢 Discuz! 开源贡献者

Click Here To See Them

升级方法

从 Discuz! X3.2 – X3.4 或其他基于此版本开发的未进行数据库结构变更的修改版本进行升级的升级流程

  1. 备份数据库和程序文件,请不要忘记备份 UCenter 数据库和程序文件。
  2. 进入您的 UCenter 所在目录(默认为 论坛根目录/uc_server),建立文件夹 old,将 UCenter 目录下除 data 目录以外的其他文件夹移动进入 old 目录中。如移动文件中存在包括但不限于 .htaccess 或 .user.ini 等的网站配置文件,请不要移动。
  3. 上传 UCenter 1.7.0 程序(压缩包中 upload/uc_server 目录中的文件,如使用 FTP 上传请使用二进制模式), 如上传时候提示覆盖目录,请选择 “是”
  4. 上传 update_ucenter_adult.php 到 UCenter 所在目录(默认为 uc_server )下的 install 目录,并删除 UCenter 所在目录下 data 目录的 update.lock 文件。
  5. 访问 UCenter 所在目录下 install 目录下的 update_ucenter_adult.php 并参照提示进行升级即可。升级时间随着数据的大小和服务器性能而变。
  6. 将除 data, config 目录,和 UCenter 所在目录(默认为 uc_server,如果该目录不在论坛根目录下的话可排除此项)以外的其他文件夹移动进入 old 目录中。如移动文件中存在包括但不限于 .htaccess 或 .user.ini 等的网站配置文件,请不要移动。
  7. 将 old/source/plugin 和 old/template 目录下除 default 以外的目录,移动回 source 和 template 目录下面(也可在上一步移动文件时,直接在原位置保留这部分文件)。
  8. 上传 Discuz! X3.5 程序(压缩包中 upload 目录中的文件,如使用 FTP 上传请使用二进制模式), 如上传时候提示覆盖目录,请选择 “是”
  9. 上传 update_adult.php 到 Discuz! 所在目录下 install 目录,并删除 Discuz! 所在目录下 data 目录的 update.lock 文件。
  10. 访问 Discuz! 所在目录下 install 目录下的 update_adult.php 并参照提示进行升级即可。升级时间随着数据的大小和服务器性能而变。

 

Discuz! X3.4 升级至 Discuz! X3.5 详细教程

由于Discuz! X3.5 对数据库有很大的调整。所以单凭覆盖文件是无法实现对Discuz!的升级。由于相关操作有些多。在不熟练的情况下请谨慎操作。

注:操作前请备份数据

1. 进入您原来的系统,关闭您的站点。进行数据备份

2. 站点建立 old 文件夹,除 data, config, uc_server, uc_client 之外的文件移动到 old 目录中

3. 下载并解压缩最新版的程序包(请注意需要与您原来的语言版本一样,不可混用) 下载地址:https://gitee.com/ComsenzDiscuz/DiscuzX/tree/v3.5/

4. 上传upload目录中的程序到服务器论坛目录,如果提示需要覆盖,则选择“是”

5. 下载 https://gitee.com/oldhuhu/DiscuzX34235 将 scheme 文件夹放在 install 目录中

6. 下载 https://gitee.com/oldhuhu/DiscuzX34235/tree/dev/ 将 update_adult.php 文件放在 install 目录中

7. 访问 http://您的域名/install/update_adult.php

8. 按照程序提示,直至所有升级完毕。

9. old 目录中如果存放有非discuz程序文件(如模板、插件、自行修改的程序文件),则恢复到原来的位置

10. 进入论坛后台,更新缓存,并对新功能进行设置和测试。

主要:由于Discuz! X3.5的程序包中,没有更新/utilities/ 目录中的 update.php文件,所以切勿使用该文件升级数据库

升级过程中,如果提示

#1227 – Access denied; you need the SUPER privilege for this operation

表明你需要超级权限来访问mysql,也就是说需要root账户。
需要打开 /config/config_global.php 将

$_config[‘db’][‘1’][‘dbuser’] =

$_config[‘db’][‘1’][‘dbpw’] =

修改为你数据库的root账号和对应的密码

发表回复

后才能评论